Swift Talk Forums HERE

New Charisma 555 12v electrics problem - help please!

This forum is now closed to new posts but remains here as a source of information. New actictivity has transferred to the Swift Talk forums (see link above).

The views expressed here are those of the individual contributors and are not necessarily those of the Club.

New Charisma 555 12v electrics problem - help please!

Postby Jockie84 » April 13th, 2009, 3:37 pm

Hi - newbie here!
Recently bought a new Charisma 555 which we love but only been to sites with 240 power since buying it - have discovered today that when 240 lead disconnected, we have no power in the van at all and I am struggling to understand why the 12v system will not function - while I am pretty good with DIY etc, electrics are my nemesis - any help appreciated.
Jockie84
Jockie84
Members
 
Posts: 2
Joined: April 13th, 2009, 3:32 pm

Re: New Charisma 555 12v electrics problem - help please!

Postby Futsal1st » April 14th, 2009, 1:36 am

I have a late 2008 Charisma 555 and have similar sought of issues. In my case the battery won't charge. I believe I have a bung charger.

In chasing this issue, I noticed that there is a fuse box under the front lounge and also a fuse on the back of the charger/ power supply.

1st step should be checking fuses.

Cheers
Paul
Futsal1st
Members
 
Posts: 2
Joined: April 13th, 2009, 6:46 am
Location: Sydney Australia

Re: New Charisma 555 12v electrics problem - help please!

Postby Jockie84 » April 14th, 2009, 9:55 am

Thanks, Paul
Will check fuses. Spoke to service manager at supplying dealer today and he was somewhat puzzled as he pointed out that the charger must be working as the 12v kit operates when the 240v hookup is connected. Going to check to see if the system operates when the car is connected - just a process of elimination, I suppose!!
Regards
Greig
Jockie84
Members
 
Posts: 2
Joined: April 13th, 2009, 3:32 pm

Re: New Charisma 555 12v electrics problem - help please!

Postby carabiker » April 14th, 2009, 10:15 am

Hi Jockie84

Check for a 20 amp in-line fuse inside the van near the battery box no always viable often tuck underneath the battery box

If need more help i can supply the name of the tech guy at Sargents electrical that supply the elec gear to Swift

Dave
Disco TD5 Conqueror 630 2008

Dyslexic key board don't look at me
User avatar
carabiker
Members
 
Posts: 139
Joined: November 6th, 2007, 7:12 pm

Re: New Charisma 555 12v electrics problem - help please!

Postby mike142sl » April 14th, 2009, 2:00 pm

Do you have the rocker switch set to VAN?
Mike
Land Rover Discovery TD5, Challenger 490se (2007)
User avatar
mike142sl
Members
 
Posts: 76
Joined: March 11th, 2007, 6:44 pm
Location: Sheffield


Return to Technical

Who is online

Users browsing this forum: No registered users and 1 guest