Swift Talk Forums HERE

Electrical problems on a Swift Challenger 560 (2008)

This forum is now closed to new posts but remains here as a source of information. New actictivity has transferred to the Swift Talk forums (see link above).

The views expressed here are those of the individual contributors and are not necessarily those of the Club.

Electrical problems on a Swift Challenger 560 (2008)

Postby donamey » April 22nd, 2009, 10:05 pm

Bought a new 2008 model in November 2008
I am on my 3rd battery charger. 1 and 2 died and No.3 is culled from one of the dealer's used vans so is OK for now and awaiting the new batch, when I should get No. 4
The Water Heater is blowing fuses on the caravan site (but not tripping the interrupter switches in the van) - Dealer is currently trying to sort this one out. It works OK on gas.
Right indicator starts out OK but after travelling for about 10 minutes it stops indicating (still works on the car though)

Any thoughts about any of the above? Are customers assumed to be the last line in quality control?
donamey
Members
 
Posts: 2
Joined: April 22nd, 2009, 8:05 pm

Re: Electrical problems on a Swift Challenger 560 (2008)

Postby carabiker » April 23rd, 2009, 8:32 am

Hi
Battery Charger
There is a known problem with vans produced between 01/05/08 and 31/08/08,

Edited Quote from Swift Group (Nordlectronica supply Swift with the chargers )

Nordlectronica in Italy. This problem was caused by their supplier who made an unauthorized component modification which in turn caused the chargers to fail prematurely. Whilst Nordlectronica have committed to replace faulty chargers and currently have engineers from their company replacing faulty units they have struggled to rectify the problem as quickly and efficiently as we would have hoped.



The Turn signal light

Clean all the pins on the plug and socket VERY slightly open up the male pins on the plug and socket

Dvae
Disco TD5 Conqueror 630 2008

Dyslexic key board don't look at me
User avatar
carabiker
Members
 
Posts: 139
Joined: November 6th, 2007, 7:12 pm

Re: Electrical problems on a Swift Challenger 560 (2008)

Postby donamey » April 23rd, 2009, 9:56 am

Thanks for the response. I have now read the Swift reply re Battery chargers and I await new supplies. Will also try your suggestion on male pins, when I get the van back from dealer
donamey
Members
 
Posts: 2
Joined: April 22nd, 2009, 8:05 pm


Return to Technical

Who is online

Users browsing this forum: No registered users and 1 guest