Swift Talk Forums HERE

a newbe with a charging problem

This forum is now closed to new posts but remains here as a source of information. New actictivity has transferred to the Swift Talk forums (see link above).

The views expressed here are those of the individual contributors and are not necessarily those of the Club.

a newbe with a charging problem

Postby bruce davey » July 3rd, 2009, 5:09 pm

Hi guys,

Just discovered your forum, hope you can help me with my problem.

I own a 1996 Sterling eccles explorer from new (stirling now owned by swift), just preparing my van to go away this weekend.

As I plug in mains, the circuit breaker on the "Plug in systems PMS7" unit trips when I switch on the battery charger. all other electrics mains and 12volt fine. I assume I have a fault with the battery charger but having searched the van unsuccessfully I asume it is integral to the PMS7 unit. This looks exspensive, anyone point me to a wiring diagram, I am confident with electonics, or a source for a replacement unit prefably second hand, thus not to much money.

A quick reply would be useful as I am off Sunday, else it will have to wait till I come back (2 weeks).

we will be on mains whilst away, so i will have to charge the battery every few days from a mobile car battery charger.

thanks

Bruce Davey
bruce davey
 
Posts: 1
Joined: July 3rd, 2009, 4:54 pm

Re: a newbe with a charging problem

Postby charles » July 6th, 2009, 10:27 am

It sounds like there is an earth fault in the charger unit or the wiring to it so check the latter before going any further. If the wiring is OK then you will need to replace the charger unit. The PMS7 module, of which the charger is part, was made by Plug In Systems (now Bonus Plug In Systems). You can contact them on 01482 373737.
User avatar
charles
Members
 
Posts: 88
Joined: February 10th, 2007, 6:25 pm


Return to Technical

Who is online

Users browsing this forum: No registered users and 1 guest

cron