Swift Talk Forums HERE

Thetford Fridge - Spanner 10 error

This forum is now closed to new posts but remains here as a source of information. New actictivity has transferred to the Swift Talk forums (see link above).

The views expressed here are those of the individual contributors and are not necessarily those of the Club.

Thetford Fridge - Spanner 10 error

Postby Stella » August 9th, 2009, 7:30 pm

Hi

I wonder if anyone can help? Just been away and never encountered this problem before - have a Thetford Fridge with an LED display (Blue light etc). Car and van connected, panel set to car battery, blue light comes on to show it's connected but then can hear a click from around the fuse board and the light starts to flash and the 10 error comes up! This keeps happening i.e. looking like it's going to work with the solid blue light and then clicking back to the error message!

Also panel above door kept switching on and off!

Checked the fuses - that's what the manual suggests, checked the plug on the car that seems OK.

Once connected to mains no problem!

Any ideas appreciated


Cheryl

Sterling Eccles Topaz and Hyundai Tucson
Stella
Members
 
Posts: 2
Joined: August 9th, 2009, 7:17 pm
Location: Nottingham

Re: Thetford Fridge - Spanner 10 error

Postby charles » August 10th, 2009, 9:28 am

Fault 10 means no “engine running” signal is present and control is in Manual DC mode. The car’s engine must be running for the fridge to work once you have selected the car as the energy source. If you do get this fault with the engine running then it may be that the car’s socket is not providing the necessary power. The fuses that supply this power are often of the ‘in line’ type and situated near the car’s battery so it’s worth checking them out.

With the engine running there should be 12+ volts across pins 6&7 on a 12S socket or across pins 10 and 11 on a 13 pin socket. For more details on the wiring of these sockets see:

http://www.a-tconsulting.co.uk/caravan_tech/12nschanges.html
http://www.a-tconsulting.co.uk/caravan_tech/13_pin_wiring_details.html

One possible option is to try hooking up your caravan to another suitable towcar. If the fault persists it may be that the fridge’s power board is faulty. In this case contact your supplying dealer who will arrange a repair.
User avatar
charles
Members
 
Posts: 88
Joined: February 10th, 2007, 6:25 pm

Re: Thetford Fridge - Spanner 10 error

Postby Stella » August 10th, 2009, 8:16 pm

Thanks - we'll give that a try
Stella
Members
 
Posts: 2
Joined: August 9th, 2009, 7:17 pm
Location: Nottingham


Return to Technical

Who is online

Users browsing this forum: No registered users and 1 guest

cron