Swift Talk Forums HERE

No water through the hot taps

This forum is now closed to new posts but remains here as a source of information. New actictivity has transferred to the Swift Talk forums (see link above).

The views expressed here are those of the individual contributors and are not necessarily those of the Club.

No water through the hot taps

Postby Giles » June 25th, 2007, 4:13 pm

I have a 1995 Swift Challenger with a Carver Cascade 2 water boiler. I’ve just taken it out of storage after the winter and am trying to get everything working. All was going well until I tried to get water to come through the hot taps. Despite allowing plenty of time for any air to come through nothing seems to be happening. All the pipe connections appear to be OK and there are no leaks. A friend suggested I might need a new boiler but I don’t want to fork out a whole load of money if I don’t have to.

Does anyone have any ideas?
Giles
Members
 
Posts: 27
Joined: June 25th, 2007, 4:02 pm

Re: No water through the hot taps

Postby KeithL » July 5th, 2007, 9:19 am

I had exactly the same problem with my van some years ago. It turned out to be a faulty one-way valve on the inlet of the heater. Apparently frost can cause ice to displace the plunger so that it prevents water from entering the heater. It is possible to reset the valve but I bought a new one just to be on the safe side. It's very easy to change.
KeithL
 
Posts: 1
Joined: July 5th, 2007, 9:07 am


Return to Technical

Who is online

Users browsing this forum: No registered users and 1 guest

cron